Los plugins de Xootix generan una brecha de seguridad crítica en WordPress

Según hemos podido conocer, una serie de plugins están provocando una vulnerabilidad crítica en las versiones actuales de WordPress. Se trata de tres plugins desarrollados por Xootix que podrían estar instalados en más de 84.000 sitios webs. Esta brecha ha sido descubierta por la investigadora Chloe Chamberland, la cual alertó del CSIRF (vulnerabilidad de falsificación de solicitud entre sitios) en el popular CMS. ¿Qué significa esto? Pues bien estamos hablando de una brecha de seguridad que se da cuando un atacante engaña a un usuario logueado enviando una solicitud web manipulada especialmente para un propósito.

Los plugins de Xootix se caracterizan por implementar mejoras en las tiendas online con WooCommerce para WordPress. Es decir, si tienes una ecommerce desarrollado con WordPress, revisa si tienes instalado alguno de estos plugins. Si la respuesta es afirmativa, no olvides actualizarlos a la última versión. Es muy importante:

Login/Signup Popup (Inline Form + Woocommerce) V 2.3 Side Cart Woocommerce (Ajax) V 2.1Waitlist Woocommerce (Back in stock notifier) V 2.5.2

El origen del fallo de seguridad reside en que las solicitudes AJAX no se validan haciendo que el atacante pueda modificar la acción «user_can_register» y cambiar el «default_role» a un rol administrador.

 

Por desgracia, el hallazgo ha llegado casi un mes después de que los atacantes ya pudieran hacer de las suyas. De hecho, explotaron estas vulnerabilidades en 15 temas de Epsilon Framework para apuntar a 1,6 millones de sitios desarrollados con WordPress como parte de una campaña de ataque a gran escala que se originó en 16.000 direcciones IP.

Lo dicho, revisa si tienes instalados estos plugins en tu CMS y, como te decimos siempre, actualízalos a la última versión para estar a salvo de posibles ataques.

Deja un comentario

Tu dirección de correo electrónico no será publicada.

Ir arriba